www.valterborsato.it

Dal Codice Fiscale ai dati: come estrarre con Excel informazioni dal CF

Dal Codice Fiscale di una persona è possibile con Excel estrarre una serie di informazioni relativamente al sesso, alla data e al luogo di nascita. Queste informazioni possono essere utilizzate anche per una verifica se i dati inseriti in altri campi sono stati imputati coerentemente rispetto al C.F.
Mentre l'individuazione del comune di nascita risulta possibile solo se si dispone dei codici dei comuni italiani, le informazione sul sesso e sulla data di nascita sono deducibili direttamente dal Codice Fiscale.
Per svolgere l'esercizio verranno utilizzate le seguenti funzioni:
SE; VALORE; STRINGA.ESTRAI; DATA; RESTO; CERCA.VERT

Estrarre del codice fiscale le informazioni sulla data di nascita e il sesso

I caratteri che indicano la data di nascita e il sesso all'interno del Codice Fiscale sono in tutto 5.
I due numeri dell’anno di nascita, sono rispettivamente il settimo e l'ottavo carattere del Codice fiscale ad esempio 1962 viene indicato con le sole due cifre 62.
Dopo i due numeri dell'anno segue una lettera che tiene conto del mese di nascita come indicato dalla tabella a lato. Infine il decimo e undicesimo carattere identificano sia il giorno di nascita, sia il sesso.
Se la persona è di sesso maschile in queste due cifre verrà riportato semplicemente il giorno di nascita. I numeri minori di dieci vengono considerati con uno zero iniziale (01, 02.....).
Se la persona è di sesso femminile, il giorno di nascita è maggiorato di 40 numeri. Le date dal 1 al 31 sono sostituite dal 41 fino al 71.

Excel: estrarre dal codice fiscale il sesso e la data di nascita | Codici mesi

Come estrarre M o F dal codice fiscale

Per verificare se la persona titolare del Codice Fiscale è Maschio o Femmina, è sufficiente verificare se il valore presenti nel decimo e undicesimo carattere è compreso da 01 a 31 (Maschio) o da 41 a 71 (Femmina).
La funzione STRINGA.ESTRAI estrae dal C.F. il decimo e undicesimo carattere, la Funzione VALORE lo trasforma in numero e infine la Funzione SE pone come Test logico che IL VALORE sia maggiore di 40. SE VERO sarà Femmina, SE FALSO Maschio.

Excel: estrarre dal codice fiscale il sesso e la data di nascita | Estrarre M o F

=SE(VALORE((STRINGA.ESTRAI(B2;10;2)))>40;"Femmina";"Maschio")

Excel: estrarre dal codice fiscale il sesso | Maschio o Femmina

L'informazione data di nascita nel Codice Fiscale

Per estrarre la data di nascita dalla stringa di caratteri che descrive il Codice Fiscale è necessario utilizzare 3 distinte funzioni STRINGA.ESTRAI
- La prima funzione STRNGA.ESTRAI, estrae semplicemente i due caratteri dell'anno in posizione 7 e 8 all'interno del C.F.
- La seconda estrae la lettera del mese. Questa funzione viene però nidificata in una funzione TROVA che chiede di trovare la posizione della lettera estratta all'interno di una stringa di 12 caratteri che rappresentano i mesi in successione da Gennaio a Dicembre. [Es. rilevato che nel CF è presente la lettera L, la funzione TROVA restituisce che questa si trova in posizione 7 della stringa "ABCDEHLMPRST"]
- La terza funzione STRINGA.ESTRAI estrae il decimo e undicesimo carattere del CF che corrisponde al numero del giorno. Se si tratta di Femmina è necessario sottrarre 40 numeri. Per fare questo senza ricorrere ad un complicata Funzione SE, basta anteporre la Funzione RESTO che ponga come divisore 40, dividendo per questa periodicità il risultato.

Excel: estrarre dal codice fiscale la data di nascita

=DATA(STRINGA.ESTRAI(B2;7;2);TROVA(STRINGA.ESTRAI( B2;9;1);"ABCDEHLMPRST");RESTO(STRINGA.ESTRAI(B2;10;2);40))

:: Le tre funzioni STRINGA.ESTRAIi sono contente nella Funzione DATA. La funzione DATA restituisce infatti il numero seriale sequenziale che rappresenta una data specifica. =DATA(anno;mese;giorno)

Excel: estrarre dal codice fiscale la data di nascita

Ricavare il luogo di nascita dal Codice Fiscale

Per ricavare il Comune di nascita dal Codice Fiscale, è necessario disporre del data base dei codici catastali di tutti i 13.866 comuni italiani.
Il Codice catastale è composto da una lettera e tre numeri che nel Codice Fiscale sono inseriti dal dodicesimo fino al quindicesimo carattere.

  XXXXXX74L71L781E

Per i nati all'estero la sigla nel Codice Fiscale inizia con la lettera Z seguita dal numero identificativo della nazione.

Per facilitare l'impostazione della funzione di ricerca, alla matrice contenente i Codici Catastali è stato attribuito il nome "comuni"

La formula per individuare il Comune di nascita dal Codice fiscale, prevede l'utilizzo della funzione STRINGA.ESTRAI per ricavare il codice composto di quattro cifre, e l'applicazione della funzione CERCA.VERT per ricercare nella matrice "comuni" la presenza del codice.
Nel caso il codice non fosse presente, verrà restituito il risultato #ND!

=CERCA.VERT(STRINGA.ESTRAI(B2;12;4);comuni;2;FALSO) 

 

:: Argomenti Correlati
-  Funzioni sui testi: Le funzioni: DESTRA; SINISTRA e STRINGA.ESTRAI
-  Funzioni condizionali: La Funzione SE
-  Matrici: La Funzione Cerca verticale CERCA.VERT
-  Estrarre la data da un testo: Utilizzo delle funzioni DATA, SINISTRA, DESTRA e STRINGA.ESTRAI

È disponibile per il download il file di Excel contenente le formule per estrarre sesso, data e luogo di nascita dal codice fiscaele. Nel secondo foglio della cartella di lavoro è presente la tabella con i codici catastali di tutti i Comuni italiani: Estrarre_dati_codicefiscale.xlsx

Indice argomenti.

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT