www.valterborsato.it

Controllare pagamenti e scadenze

In Excel può rendersi necessario creare dei monitoraggi rispetto scadenze di pagamenti o di consegne da effettuare entro un certo numero di giorni.

Questo tipo di situazione si riscontra frequentemente nell'utilizzo aziendale di Excel. Le Funzioni e i comandi necessari per organizzazione un Foglio di lavoro che risponda a queste necessità sono le seguenti:
- Funzione OGGI
- Funzione SE
- Formula per il calcolo giorni fra due date, oppure Funzione DATA.DIFF
- Comando Formattazione condizionale.

Creare una griglia di monitoraggio e impostare un aggiornamento automatico della data.

Per meglio articolare la spiegazione delle Formule e Funzioni è conveniente ipotizzare un esempio, che potrà essere declinato su situazioni analoghe nelle quali risultasse fondamentale il monitoraggio del trascorrere di un certo numero giorni a partire da una data.

Nell'esempio, (si veda la sottostante immagine) si ipotizza la consegna a dei clienti di oggetti sottoposti a riparazione. Rispetto questa azione si vuole monitorare il trascorrere dei giorni di tempo per l'incasso del pagamento, definito a 60 giorni data dalla consegna del lavoro.

Excel Monitorare scadenze e pagamenti con la formattazione condizionale 

Nella cella D2, è stata inserita la funzione =OGGI()
Questa funzione è utilissima nei casi in cui fosse necessario visualizzare la data corrente all'interno di una cella del foglio di lavoro, indipendentemente da quando questo venisse aperto.

:: Attenzione, il corretto aggiornamento della funzione OGGI è fornito dall'orologio del sistema operativo. Il valore restituito da questa funzione cambia solo quando si ricalcola il foglio di lavoro o si avvia il foglio di lavoro.

Excel: calcolare giorni trascorsi e monitorare scadenze e pagamenti

Calcolo del numero di giorni di ritardo del pagamento

Per ottenere il numero di giorni trascorsi dalla data di fine lavoro è possibile impostare una formula che sottragga dalla funzione OGGI() la data della consegna del lavoro di riparazione ai clienti. Nell'esempio dell'immagine sopra raffigurata la funzione inserita nella cella F5 è la seguente: $D$2-D5
Per poter trascinare la formula anche nelle sottostante righe è necessario che il riferimento alla cella D2 (contenente la data odierna) sia assoluto.

Excel: la formattazione condizionale per monitorare scadenze e pagamenti

La formattazione condizionale, come strumento di analisi del ritardato pagamento

Dopo aver selezionato l'intervallo di celle F5:F9 sulla scheda HOME selezionare il comando Formattazione condizionale e scegliere le successive opzioni: Regola evidenziazione celle e Maggiore di...

Excel: impostare la formattazione condizionale per monitorare scadenze e pagamenti

Una volta cliccato Maggiore di... comparirà la finestra di dialogo nella quale è possibile impostare i criteri della formattazione condizionale.
Formatta celle con valore maggiore di: 60 con: Riempimento rosso chiaro con testo rosso scuro.

Excel: impostare la formattazione condizionale per monitorare scadenze e pagamenti

Cliccando sul pulsante del menu a tendina, a destra della voce Riempimento rosso chiaro con testo rosso scuro, è possibile scegliere fra altre formattazioni condizionali già predefinite da Excel.
Qualora si intendesse personalizzare il colore della formattazione, selezionando l'opzione Formato personalizzato... si apre la finestra di dialogo Formato celle nella quale è possibile impostare carattere, bordo e colore di riempimento.

Excel: personalizzare la formattazione condizionale per monitorare scadenze e pagamenti

Inserire un messaggio di avvertimento con la Funzione logica SE

Monitorare un pagamento con la Funzione SE.
In alternativa alla formattazione condizionale, è possibile creare un Alert con una funzione SE che possa esprimere un testo di attenzione qualora i tempi massimi previsti per il pagamento fossero stati superati.
nello specifico per la cella F5 la funzione potrebbe essere impostata nel seguente modo: =SE(F5>60;"solleciare pagamento";"OK")

Excel: la funzione SE per monitorare scadenze e pagamenti

Funzione SE nidificata per monitorare diversi livelli di criticità.
Sarebbe possibile considerare anche più livelli di attenzione alle scadenze dei pagamenti.
Ad esempio, considerare un messaggio più incisivo qualora i giorni trascorsi fossero ad esempio più 90. In questo caso nella condizione VERO maggiore di 60 della prima funzione SE, andrebbe inserita una seconda funzione SE che verifichi se il ritardo è oltre i 90 giorni.
=SE(F5>60;SE(F5>90;"mancato pagamento";"ritardo pagamento");"OK")

Excel: la funzione SE annidata per monitorare scadenze e pagamenti

:: Argomenti correlati:
Excel: La formattazione condizionale
Excel: Formato data | Calcolare giorni, mesi e anni fra due date. Le funzioni ANNO; MESE; OGGI; ADESSO
Excel: Funzioni logiche | La funzione SE (prima parte)
Excel: Funzioni logiche | La funzione SE (seconda parte) utilizzo degli operatori E, O, NON

Indice generale argomenti:

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT

 

Download del Foglio di Excel contenente l'esempio trattato nella spiegazione.