www.valterborsato.it

Applicare le Funzioni SOMMA SE e CONTA SE

Le Funzioni SOMMA SE e CONTA SE permettono rispettivamente di sommare o contare i valori presenti in un intervallo di celle che soddisfano un determinato criterio logico.
Le Funzioni SOMMA.PIÙ.SE e CONTA.PIÙ.SE, permettono di sommare o contare le celle di un intervallo che soddisfano più criteri.
:: Le Funzioni SOMMA.PIÙ.SE e CONTA.PIÙ.SE sono disponibile in Excel solo a partire dalla versione 2010.

La Funzione SOMMA.SE

La sintassi della Funzione è la seguente:
=SOMMA.SE(intervallo;criterio;[int_somma])
nella quale:
intervallo
: è l’intervallo nelle quali cercare i valori;
criterio
: definisce la condizione del valore da ricercare nell'intervallo;
Int_somma
: definisce le celle che, se si verifica la condizione, verranno sommate da Excel.

Esempio di applicazione della Funzione SOMMA.SE

Si consideri per la tabella sottostante la necessità di calcolare il fatturato complessivo di un solo venditore (ad esempio Rossi). Il riferimento al venditore potrà essere indicato o facendo riferimento ad una cella entro cui è imputato il nome o inserendo il nome stesso fra doppi apici all'interno della formula. Sarà possibile esprimere la Funzione nel seguente modo: =SOMMA.SE(C:C;"Rossi";F:F)  Ovvero: Intervallo tutta la colonna C:C; criterio "Rossi" int_somma tutta la colonna F:F
::Nota. Nel definire l'area dell'intervallo e dell'int_somma, è possibile fare riferimento all'intera colonna del foglio di lavoro indicando rispettivamente con C:C e F:F tutta la colonna C e F del foglio di lavoro.

Excel | La funzione SOMMA.SE - Applicare somma se

Utilizzare due soli argomenti della funzione SOMMA.SE

Ulteriore esempio di applicazione della Funzione SOMMA.SE utilizzando solo due argomenti della Funzione.
Come espresso dalla sintassi: =SOMMA.SE(intervallo;criterio;[int_somma]) il terzo argomento della Funzione essendo indicato fra parentesi quadrata  [int_somma]  è opzionale.
E' possibile pertanto utilizzare anche solo i primi due argomenti della Funzione SOMMA.SE nel caso in cui la colonna nella quale verificare il criterio, sia la stessa da sommare.

Esempio immagine sottostante.
Si vogliono sommare solo i numeri positivi, pertanto si imposta il criterio che i valori contenuti nell'intervallo delle celle B2:B6 siano maggiori di zero.
=SOMMA.SE(B2:B6;">0")
:: Attenzione. Il criterio maggiore di zero ">0"  all'interno della Funzione deve essere espresso fra doppi apici.

 La funzione SOMMA.SE - Esempio di applicazione

La Funzione CONTA.SE

La funzione CONTA.SE conteggia il numero di celle presenti in un determinato intervallo che soddisfano un specificato criterio.

La sintassi della Funzione è la seguente
=CONTA.SE(intervallo;criterio)
dove:
intervallo
: definisce l'area del foglio di lavoro nella quale cercare i valori;
criterio
: è l'espressione della condizione affinchè i valori siano computati.
Esempio. Se si volesse  calcolare quante volte compare il venditore Rossi nell'elenco delle operazioni di vendita. La funzione sarebbe la seguente =CONTA.SE(C:C;"Rossi")
Ovvero conta, cercando nell'intera colonna C:C quante volte compare il valore "Rossi" (il criterio deve essere indicato fra doppi apici).

Excel: la Funzione CONTA.SE - Applicare la funzione conta se. 

La Funzione CONTA.PIÙ.SE

La Funzione CONTA.PIÙ.SE permette di impostare più condizioni di calcolo.

La sintassi è la seguente
=CONTA.PIÙ.SE(int_criteri1;criteri1;[int.criteri2; criteri2]…....)
Nell'impostare la Funzione devono essere elencanti nell'ordine il primo intervallo di criterio; e di seguito la definizione del primo criterio.
Successivamente dovrà essere indicato il secondo intervallo di criterio; e il secondo criterio;  e a seguire "n" possibili successivi intervalli e criteri.
Es. Se si volesse contare quante volte Rossi ha fatturato nella Regione Veneto, la funzione sarebbe la seguente
=CONTA.PIÙ.SE(C:C;"Rossi";D:D;"Veneto")

Excel | La funzione CONTA.PIÙ.SE - Esempio applicazione della Funzione conta più se 

La Funzione SOMMA.PIÙ.SE

La Funzione SOMMA.PIÙ.SE analogamente alla Funzione CONTA.PIù.SE, ha la possibilità di calcolare i valori contenuti nelle celle di un determinato intervallo che soddisfano più criteri.

La sintassi della formula è la seguente:
=SOMMA.PIÙ.SE(int.somma;int.criteri1;criteri1; int.criteri2;criteri2… )

Il primo operatore che va inserito nella Funzione è l'intervallo da sommare (int_somma). Successivamente vanno indicati il primo intervallo di criteri e il primo criterio; il secondo intervallo di criteri e il secondo criterio e così a seguire ....

Esempio se si volesse sommare il fatturato del venditore Bianchi nella sola Regione Lombardia la formula sarebbe la seguente:
=SOMMA.PIÙ.SE(F:F;C:C;"Bianchi";D:D;"Lombardia")

Excel | La Funzione SOMMA.PIÙ.SE 

Applicare i caratteri jolly nelle ricerche

::Approfondimento.  Le funzioni SOMMA.SE; SOMMA.PIÙ.SE; CONTA.SE; CONTA.PIÙ.SE nell'impostazione dei criteri posso utilizzare i caratteri jolly.
I caratteri Jolly utilizzabili sono l'asterisco e il punto di domanda. L'asterisco sostituisce qualsiasi stringa che precede o segue una parola specificata. Il punto di domanda, sostituisce qualsiasi lettera all'interno di una stringa di testo.
Esempio: 
Ros* potrebbe considerare qualsiasi venditore il cui nome contiene la stringa di testo "ros"
R?ssi invece potrebbe restituire sia Rossi sia Russo, ma non il valore Rossini !


E' possibile scaricare il file Excel contente gli esempi sull'utilizzo delle funzioni SOMMA.SE; SOMMA.PIÙ.SE; CONTA.SE; CONTA.PIÙ.SE.

Argomenti correlati

Le Funzioni Logiche di Excel
    - Funzioni logiche: Funzione SE prima parte. La Funzione SE (sintassi e operatori logici di confronto)
    - Funzioni logiche: Funzione SE seconda parte. Applicare gli operatori connettivi. Le Funzioni E; O; NON
    - Funzioni logiche: Utilizzare le Funzioni SOMMA.SE; SOMMA.PIÙ.SE; CONTA.SE; CONTA.PIÙ.SE
    - Funzioni logiche: La Funzione SE.ERRORE e la correzione dei messaggi di errore di Excel
    - Esercitazioni ed esempi: Dodici esempi pratici di applicazione della Funzione logica SE

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT