www.valterborsato.it

La Funzione RIF.COLONNA e la Funzione RIF.RIGA

La Funzione RIF.COLONNA di Excel restituisce il numero della colonna di riferimento di una cella specificata.
Ad esempio, la formula =RIF.COLONNA (C10) restituisce il numero 3, perché la colonna C è la terza colonna del foglio di lavoro.
La Funzione RIF.RIGA viceversa, restituisce il numero di riga di un riferimento.
Entrambe queste Funzioni trovano un'interessante applicazione soprattutto se vengono annidiate all'interno di altre Funzioni quali ad esempio funzioni di ricerca come CERCA.VERT; CONFRONTA; INDICE etc.

Sintassi della Funzione RIF.COLONNA

=RIF.COLONNA([rif])
nella quale:
rif: (Argomento facoltativo) rappresenta il numero della colonna di riferimento di una cella o di un intervallo di celle (matrice).

Esempio di applicazione della Funzione RIF.COLONNA

Funzione molto semplice nella sua impostazione, il cui interesse è legato alla nidificazione all'interno di altre funzioni o alla creazione di contatori.
Nella Cella B3 è inserita la Funzione =RIF.COLONNA(D1), il cui unico argomento e il riferimento alla cella D1 del foglio di lavoro. il risultato è quattro poichè la cella D1 si trova nella quarta colonna del folgio di lavoro di Excel.
Qualora non fosse indicato l'unico argomento (facoltativo) della Funzione, se nella cella B3 venisse imputata la Funzione =RIF.COLONNA() il risultato restituito sarebbe 2, ovvero il numero della colonna della cella B3, nella quale è stata inserita la Funzione.

Funzioni di Ricerca e Riferimento di Excel: RIF.COLONNA E RIF.RIGA:  

Nella Funzione RIF.COLONNA è possibile fare riferimento ad una matrice dati.
Se nella cella B3 viene inserita la Funzione =RIF.COLONNA(A1:F1) il risultato come evidenziato nella barra della Funzione è una matrice (vedi immagine sottostante).
Dalla versione 2019 e 365 di Excel sono disponibili le funzioni di matrice dinamica. In queste versioni, se viene imputata la Funzione =RIF.COLONNA(A1:F1) in tutte le celle adiacenti vengono proposti i valori 1, 2, 3, 4, 5, 6  rispettivamente i riferimenti della matrice dalla colonna 1 alla 6 (A1:F1).
Sulla barra della Formula selezionando la Funzione e premendo il tasto F11 viene evidenziata la matrice {1\2\3\4\5\6}.
Nelle versioni precedenti alla 2019 o alla 365, non avviene questa espansione nelle celle adiacenti e come risultato viene inserito il numero della colonna del prima cella dell'intervallo dati, nel caso del nostro esempio =RIF.COLONNA(A1:F1) il numero 1.

Funzioni di Ricerca e Riferimento di Excel: RIF.COLONNA E RIF.RIGA: risultato applicazione funzione 

Nidificare la Funzione RIF.COLONNA nella Funzione CERCA.VERT

Applicabile da Excel 2019 o 365.  
Nella sottostante immagine, si vuole ricercare all'interno della matrice F3:I8, la categoria prodotto, il modello e il prezzo unitario riferito al codice prodotto a2.
Normalmente per ottenere queste informazioni, nelle celle B3, C3 e D3, si dovrebbero inserire 3 distinte Funzioni CERCA.VERT che andranno ad estrarre della matrice F3:I8 rispettivamente l'indice 2, 3 e 4.
Sfruttando l'espansione dati offerta dalle matrici dinamiche, è possibile imputare un'unica Funzione nella cella B3 e indicare i riferimenti di matrice attraverso la Funzione RIF.COLONNA
=CERCA.VERT(A3;F3:I8;RIF.COLONNA(B1:D1);0)
Nello specifico, il primo argomento è il valore che si vuole ricercare (ovvero il riferimento della cella contenente il codice a2), Il secondo argomento individua la matrice dati nella cui prima colonna deve essere ricercato il codice. il terzo argomento rappresenta il riferimento all'indice (ossia la colonna) che vogliamo sia restituita. il quarto argomento 0 (zero) oppure falso indica che la ricerca deve essere esatta e non per approssimazione.
Come terzo argomento, ovvero l'indice, al posto di definire una specifica colonna è stata inserita la Funzione RIF.COLONNA e come argomento è stato indicato un intervallo di celle (B1:D1) che restituisce i valori 2, 3 e 4 (ossia gli indici delle colonne che restituiscono la categoria prodotto, il modello e il prezzo unitario riferito)
Ovviamente sarebbe stato uguale scegliere un riferimento diverso quale B12:D12 l'importante è che questo restituisca sempre i valori 2, 3 e 4. in quanto le colonne B, C e D si trovano in queste specifiche posizioni.
Una volta inserita la Funzione nella cella B3, premendo invio, la Funzione si espande automaticamente anche alle successive celle C3 e D3 restituendo correttamente i valori presenti nella matrice dati.
:: Per chiarimenti sulla Funzione CERCA.VERT si rimanda a: La Funzione CERCA VERT di Excel

Funzioni di Ricerca e Riferimento di Excel: RIF.COLONNA E RIF.RIGA: annidiare la Funzione RIF.COLONNA all'interno della Funzione CERCA.VERT 

 

Sintassi della Funzione RIF.RIGA

=RIF.RIGA([rif])
nella quale:
rif: (Argomento facoltativo) rappresenta il numero della riga del foglio di lavoro in riferimento ad una cella o ad un intervallo di celle (matrice)

Esempio di applicazione della Funzione RIF.RIGA

Come precedentemente espresso per RIF.COLONNA, queste Funzioni non sembrerebbero di grande utilità se applicate da sole, ma possono tornare molto utili nidificate all'interno di Funzioni di Ricerca.
Per quanto riguarda la nidificazione nella Funzione CERCA.VERT nella definizione di più indici si potrebbe tranquillamente impostare anche RIF.RIGA al posto di RIF.COLONNA, quello infatti che interessa e la restituzione di una matrice che andrà ad individuare gli indici.
Nel caso specifico di RIF.RIGA (come evidenziato nella sottostante immagine) nel processo di espansine della matrice dinamica, i risultati non vengono elencati orizzontalmente ma verticalmente in basso rispetto la cella nella quale è stata imputata la Funzione =CERCA.VERT(A3;F3:I8;RIF.RIGA(K2:K4);0)

Funzioni di Ricerca e Riferimento di Excel: RIF.COLONNA E RIF.RIGA: annidiare la Funzione RIF.COLONNA all'interno della Funzione CERCA.VERT

Un'altra interessante applicazione della Funzione RIF.RIGA, potrebbe essere quella di creare un contatore all'interno di in una formula che successivamente dovesse essere trascinata.
Per esemplificarne il risultato, la Funzione RIF.RIGA in questo caso viene inserita da sola e non nidificata.
Esempio: si supponga di avere la necessità di creare un progressivo numerico che inizi con il numero 1 a partire dalla cella B3.
Nella cella B3 può essere inserita la seguente Funzione: =RIF.RIGA()-2  (il -2 serve per correggere il reale riferimento della cella B3 che sarebbe 3)

Funzioni di Ricerca e Riferimento di Excel:  RIF.RIGA

Indice Generale Argomenti: EXCEL