www.valterborsato.it
 

I caratteri jolly

Un carattere Jolly o Metacarattere è un carattere che, inserito in una stringa, non rappresenta più se stesso bensì un insieme di altri caratteri o sequenze di caratteri. I due caratteri jolly che Excel applica in molte ricerche e Funzioni sono l'asterisco "*" e il punto di domanda "?"
Nello specifico l’asterisco “*” è il carattere jolly che viene utilizzato in sostituzione di una stringa di caratteri (due o più caratteri sequenziali) mentre il punto interrogativo “?” ne sostituisce uno soltanto ma, come verrà successivamente approfondito, ne esige la presenza ovvero deve esserci un carattere in quella precisa posizione.

Applicare i caratteri jolly nelle ricerche di Excel

L'utilizzo dei caratteri jolly trova sicuramente applicazione e forte interesse nei filtri di Excel, soprattutto nei filtri avanzati. (Scheda DATI, gruppo pulsanti Ordina e Filtra, comando Avanzate).
Per un approfondimento sui Filtri avanzati si rimanda a: Filtri avanzati di Excel
Passiamo pertanto ad illustrare alcune ricerca dati applicando i caratteri jolly.

Applicazione del carattere jolly asterisco "*" nei Filtri avanzati di Excel

Esempio 1. si vogliono ricercare all'interno di una tabella, tutti i nominati il cui cognome inizia con la stringa ROS (vedi immagine sottostante). Nell'impostazione del criterio basterà indicare ROS*
Questa impostazione del criterio restituisce solo i nominativi di coloro che iniziano per Ros ma non che contengono la stringa esempio il cognome Morosetti non viene restituito!
OSSERVAZIONI: Nelle ricerche con i Filtri avanzati non fa differenza la scrittura maiuscolo o minuscolo (non è case sensitive).

 Applicare i caratteri Jolly nei Filtri avanzati di Excel: Applicazione del carattere jolly asterisco

Qualora nella ricerca si volessero individuare tutti i nominativi che contengono la stringa ros, l'impostazione del criterio del Filtro avanzato dovrebbe essere *ros
Questa impostazione del criterio, al contrario della precedente, restituisce i nominati che iniziano, contengo o finiscono con la stringa ros.

Applicare i caratteri Jolly nei Filtri avanzati di Excel: Applicazione del carattere jolly asterisco

Applicazione del carattere jolly punto di domanda "?" nei Filtri avanzati di Excel

Come anticipato, il punto interrogativo “?” sostituisce soltanto una carattere ma ne esige la presenza ovvero deve esserci un carattere in quella posizione.
Cosa significa questo? Che se ad esempio nella ricerca di una stringa all'interno di un codice si cercassero i caratteri *VTR Excel restituisce tutti i valori che contengono quello specifico gruppo di caratteri. Viceversa se venisse impostata una ricerca del tipo ???VTR la stringa dei caratteri VTR dovrà essere solo, nella posizione 4,5 e 6 del testo. In quanto prima di essi dovranno esserci tre caratteri qualsiasi. il punto di domanda diventa pertanto come un segnaposto che deve essere rappresentato dalla presenza di un carattere.

Applicare i caratteri Jolly nei Filtri avanzati di Excel: Applicazione del carattere jolly punto di domanda

ATTENZIONE! Nella ricerca di gruppi di caratteri all'interno di un testo, potrebbe essere necessario individuare specificatamente dei caratteri che coincidono con i carattere jolly!
Esempio in un codice potrebbe essere presente l'asterisco.
Ovviamente non sarebbe possibili indicare questo carattere con l'asterisco stesso poichè questo vorrebbe significare qualsiasi valore!
Per questa particolare ricerca si deve utilizzare il carattere ˜ (tilde) che non è un carattere jolly, ma serve nel raro caso in cui vogliamo cercare proprio un asterisco o un punto di domanda all'interno di una stringa di dati.  Per usarlo bisogna farlo precedere all'asterisco o al punto di domanda.
Per digitare la tilde "˜" si deve tenere premuto il tasto Alt e digitare 126 nella tastiera numerica.

Esempio se volessimo cercare la stringa  "VTR*"  bisognerebbe digitare il criterio espresso nel seguente modo VTR˜* in questa modalità l'asterisco non verrebbe più letto come un carattere jolly ma come uno specifico carattere da ricercare.

Applicare i caratteri jolly nelle Funzioni Excel

Non tutte le funzioni di Excel accettano i caratteri jolly.
Questi caratteri tornano utili in alcune funzioni di ricerca e riferimento o di somma, media e conteggio.
Nelle specifico le Funzioni che possono supportare i caratteri jolly sono SOMMA.SE CONTA.SE CERCA.VERT e CERCA.ORIZZ (in questo caso solo se l’argomento intervallo è impostato come falso oppure 0) CONFRONTA (sempre quando quando l’argomento corrispondenza è impostato falso oppure 0)
In questa sezione vengono riportate una serie di esempi di applicazioni dei caratteri jolly all'interno di Formule e Funzioni.
Le più recenti Funzioni CERCA.X piuttosto che CONFRONTA.X prevedono al loro interno uno specifico argomento di impostazione della ricerca tramite caratteri jolly.
Per un approfondimento dell'impostazione della sintassi e del carattere jolly nella Funzione CERCA.X vedi: La nuova Funzione CERCA.X
Per un approfondimento dell'impostazione della sintassi e del carattere jolly nella Funzione CONFRONTA.X vedi: Applicare le funzioni CONFRONTA e CONFRONTA.X

Esempi di applicazione dei caratteri jolly nelle Funzioni di Excel

Nell'esempio proposto nell'immagine di cui sotto, è presente una lunga tabella dati che rappresenta fatturati di alcune province per determinati settori.
Ora consideriamo che sia necessario fare la somma (l'esempio potrebbe essere declinato anche per la media o il conteggio) del fatturato di un specifico comune. Ad esempio Verona o Venezia. Qualora si volesse calcolare assieme il totale del fatturato di queste due province è possibile utilizzare il carattere jolly Ve*, ovvero i comuni che inizio per Ve e successivamente presentano qualsiasi altra serie di caratteri.
Nello specifico la funzione potrebbe essere impostata come: =SOMMA.SE(C:C;"Ve*";E:E)
Il criterio "Ve*" deve essere obbligatoriamente inserito fra doppi apici
Con la medesima modalità potrebbe essere impostata anche la Funzione CONTA.SE e MEDIA.SE

Applicare i caratteri Jolly nelle Funzioni di Excel

Esempi di applicazione dei caratteri jolly nelle Funzioni di Ricerca e Riferimento

Nell'esempio proposto nell'immagine, si vuole cercare all'interno della tabella il prezzo di un prodotto il cui nome inizia per "Sc".
La Funzione che viene impostata è la seguente =CERCA.VERT("Sc*";B3:C15;2;0)
Il risultato che la Funzione restituisce è 97, ossia il prezzo del primo prodotto che soddisfa la ricerca.

Applicare i caratteri Jolly nelle Funzioni di Excel

ATTENZIONE. Nell'impostare una Funzione di Ricerca e Riferimento come il CERCA.VERT (ma varrebbe anche per altre Funzioni quali ad esempio CONFRONTA) il Valore che viene restituito è sempre uno solo e più specificatamente il primo valore (risultato) che soddisfa la ricerca, tutti gli altri valori seppur compatibili con la ricerca non vengono considerati.

lo sviluppo si alcune funzioni come la recente Funzione CERCA.X e CONFRONTA.X, prevedono all'interno dei loro argomenti specificatamente una impostazione per i caratteri jolly
Esempio la sintassi della Funzione CERCA.X è la seguente:
=CERCA.X(Valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca])
Nel quinto argomento [modalità_confronto] è possibile inserire i seguenti codici: 0 = corrispondenza esatta; -1 corrispondenza esatta o elemento successivo più piccolo; 1 = corrispondenza esatta o numero successivo più grande; 2 = corrispondenza carattere jolly;
Analogamente anche la Funzione CONFRONTA.X ha la possibilità di impostare l'argomentazione di corrispondenza carattere jolly

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT