www.valterborsato.it

Il messaggio di errore #N/D di Excel

Il Codice di errore #N/D segnala che rispetto ad una ricerca effettuata da una Funzione, il valore richiesto non è disponibile.
Un esempio classico sulla restituzione di questo messaggio di errore, è avere impostato un dato di ricerca inesistente nell'argomento "valore" nelle seguenti Funzioni: CERCA.VERT, CERCA.ORIZZ, RICERCA, CONFRONTA.

La presenza nel Foglio di lavoro del messaggio #N/D, non è solo un "disturbo" rispetto all'eventualità di stampare il documento o inviarlo ad un cliente, ma impedisce di effettuare delle operazioni di calcolo nelle colonne che contengono il codice di errore.
Ad esempio risulterebbe impossibile sommare una colonna contenente dei codici di errore con una semplice funzione SOMMA."style3">  

Cancellare il messaggio di errore #N/D dai Fogli di stampa di Excel

Se il messaggio di errore #N/D non crea problemi nelle Formule e Funzioni, ma rappresenta solo una fastidiosa presenza nella stampa del documento, è possibile risolvere il problema impostando una opzione nella scheda Foglio della finestra di dialogo imposta pagina.

Nella scheda Foglio della finestra di dialogo Imposta pagina alla voce Errori cella come: impostare l'opzione <vuoto>
Ovviamente i codici di errore rimarranno visibili sul foglio di lavoro ma non verranno stampati!

Gestire il messaggio di errore #N/D | Cancellare il messaggio di errore #N/D dai fogli di stampa di Excel

Come calcolare un'area dati contente messaggi di errore

Se si deve impostare una Funzione di SOMMA, per una area dati che contiene dei codici di errore, quale risultato della Funzione viene restituito lo stesso codice di errore rilevato nell'area dati da sommare.
Al posto della Funzione SOMMA è possibile utilizzare la Funzione AGGREGA.
La Funzione AGGREGA permette di supportare 19 diverse Funzioni di Excel, con l'opzione di poter ignorare righe nascoste e/o i valori di errore.

 

Gestire il messaggio di errore #N/D | Come calcolare un'area dati contente messaggi di errore

LaLa Funzione AGGREGA dispone due diverse sintassi rispettivamente denominate di Riferimento e Matrice.
Riferimento =AGGREGA(num_funzione, opzioni, rif1, [rif2], …)
Matrice =AGGREGA(num_funzione; opzioni, matrice [k])

Nel caso dell'immagine sopra raffigurata è possibile sostituire la Funzione =SOMMA(F19;F26) con la seguente espressione:
=AGGREGA(9;6;F19:F26)
Nella quale il numero Funzione 9 rappresenta la SOMMA; l'opzione 6 indica alla Funzione di ignorare i messaggi di errore; ed infine F19:F26 rappresenta la matrice dati su cui applicare la Funzione 9 ovvero una somma.
le Funzione e le opzioni considerate dalla Funzione AGGREGA sono illustrati nella immagine sottostante.

Gestire il messaggio di errore #N/D

 

Eliminare i codici di errore dal Foglio Excel con la Funzione SE.ERRORE

La Funzione SE.ERRORE rappresenta sicuramente una soluzione definitiva ai problemi prodotti dai messaggi di errore, sia nelle stampe sia nelle Funzioni presenti sul Foglio di calcolo.
Nella sua sintassi la Funzione se errore dispone di due argomenti, il primo (valore) è la Formula nella quale si vuole verificare la presenza di un eventuale errore. Il secondo argomento (se_errore) è il testo (oppure una stringa vuota) da restituire se la Formula fornisce come risultato un errore.

Sintassi:
=SE.ERRORE(valore;se_errore)
La Funzione SE.ERRORE considera i seguenti tipi di codici: #N/D, #VALORE!, #RIF!, #DIV/0!, #NUM!, #NOME? o #NULLO!.
Per un approfondimento sulla Funzione SE.ERRORE vedi Applicare la Funzione SE.ERRORE per gestire i messaggi di errore di Excel

Esempio di applicazione. Nell'immagine sotto raffigurata la Funzione CERCA.VERT, viene inserita nell'argomento valore della Funzione SE.ERRORE.
Nel caso la Funzione di ricerca dovesse restituire un codice di errore #N/D, con il secondo argomento della Funzione SE.ERRORE viene indicato di restituire una stringa vuota, indicata nell'espressione con due doppi apici "".
=SE.ERRORE(CERCA.VERT(B19;lista;4;FALSO);"")

Gestire il messaggio di errore #N/D | Eliminare i codici di errore dal Foglio Excel con la Funzione SE.ERRORE

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT